Updates made to KITE® Suite

08/31/17

An updated KITE Client has been released, which will support new features available on student assessments. KITE Client 5.0 is required for testing in 2017–18. Schools should update to the new client at their earliest convenience.

An update has also been released for KITE Suite’s Local Caching Server (LCS), which will support the updated version of KITE Client. The LCS is not required for testing.

KAP recommends the LCS where internet connectivity is unreliable. It allows a computer to act as a dedicated network server for testing with KITE Client, which gives testing devices local access to test content and provides response storage. This helps schools or districts with limited internet connectivity maintain a smooth testing experience.

Schools and districts planning to use the LCS for KAP testing should download the new installer from this website. Users opening an outdated LCS will be prompted to download the new installer before continuing with the application.